Toolbar / Command Bar


(Redirected from Toolbar)

Main pageMotive DocumentationToolbar / Command Bar

Page Scope

This page lists out the options that are available on the toolbar and the command bar of Motive.

Motive Command Bar
The Motive Toolbar

Toolbar[edit]


The Motive Toolbar
Icon Function Description
Toolbar Open 20.png
Open File Open Motive files: Project (TTP), Calibration (CAL), Takes (TAK), Rigid bodies (TRA), Skeletons (SKL).
Toolbar Save 20.png
Save Current Take Save currently opened Take.
Toolbar SaveAll 20.png
Save All Takes Save all of the Takes that are loaded in the Data Management pane.
Toolbar AppSettings 20.png
Application Settings Opens Application Setting pane for software preferences. Reconstruction settings will also be modified in this pane.
Tb8.png
Hide all panes Closes all the panes in the layout, leaving only the main viewport.
Toolbar Device Icon.png
Devices pane Opens the Devices (Cameras) Pane
Toolbar Calib 20.png
Calibration pane Opens Calibration Pane
Toolbar Data Icon.png
Data Management pane Opens the Data Management pane for managing takes.
Toolbar Assets Icon.png
Assets pane Opens the Assets pane for managing the list of tracked assets as well as integrated devices such as force plates and data acquisition devices.
Toolbar Properties Icon.png
Properties pane Opens the Properties pane for managing the properties of selected items in Motive.
Toolbar Info .png
Info pane Opens the Info pane for monitoring real-time tracking data of a selected rigid body in Motive.
Toolbar RigidBody .png
Builder pane Opens the Builder pane for defining or modifying rigid body or skeleton assets in Motive.
Toolbar Markerset Icon.png
Markersets pane Opens the Markersets pane for creating and configuring markersets.
Tb19.png
Edit Tools Pane Opens Edit Tools for post-processing pipelines.
Toolbar Labeling Icon.png
Labeling pane Opens the Labeling pane for labeling the markers.
Toolbar GraphViews Icon.png
Graph View pane Opens Graph View pane for monitoring the channel data.
Toolbar Stream 20.png
Data Streaming pane Opens Data Streaming pane for configuring the streaming properties.
Toolbar Log 20.png
Status Log Opens the Status Log for monitoring the activity.
Toolbar Views 20.png
View Pane Adds extra View panes.
ToolBar ReferenceView 20.png
Reference View Pane Opens the view pane for monitoring reference videos with assets overlay.

Command Bar[edit]


File[edit]

Options under the File tab.

Open: Prompts user to select a file to open. Applicable files include Take files (.tak), Camera Calibration files (.cal), Motive user profile (.motive), Rigid Body definitions (.tra deprecated), Skeleton defintions (.skl deprecated).

Add Session Folder: Adds a session folder to the Data pane in Motive. This will list all of the available TAK files within the session folder.

Import Shot List: Import a list of Take names to record from a CSV file that contains Take names on each row This allows users to plan which motions to capture ahead of the time. See: Data Recording page.

Save Current Take: Saves currently opened Take.

Save Current Take As: Prompts the user to select a filename and a directory to save the current Take.

Save All Takes: Save all Takes from all of the sessions loaded in the Data Management pane.


Info2.png

Profile (MOTIVE) files: MOTIVE profile stores software configurations. Software setting such as applications settings, streaming setting, trackable assets, synchronization configurations, and/or device configurations can be saved into this file. This file can be exported and imported to configurations in Motive.

Update Default Profile: Manually update the current software configurations onto the default system profile. Which loads up at first when launching Motive and located under C:\ProgramData\OptiTrack\MotiveProfile.motive.

Export Profile As...: Exports the current software configurations into an application profile (MOTIVE).

Export Assets...: Export just the assets (rigid bodies, skeletons, markersets) to a MOTIVE file.


Export Camera Calibration: Exports the current system calibration file(.cal) to a desired location.


Export Tracking Data: Exports tracking data from a selected Take into the desired output format. See: Data Export.

Export Video: Exports reference video to an AVI file. To play this file in Windows Media Player, a codec needs to be installed.

Export Take Info: Exports basic information of each TAK in the currently loaded session folder.


Recent Files: Displays a list recently opened Take files. This list will display the director of the recent files.


Exit: Closes the Motive application.

Edit[edit]

Options under the Edit tab.

Undo: Reverts data processing actions (i.e. deleting data, merging markers, filling gaps).

Redo: Reverts an Undo.


Trim Current Take: Archives the original take file and crops out the working range selected in the Graph View pane. For more information, read through the Trimming Captured Takes.


Application Settings: Opens the Application Settings pane.

Mouse Controls: Opens Mouse Controls pane for configuring mouse controls.

Hotkeys: Opens the Hotkey Editor pane for configuring custom Hotkeys

Reset Application Defaults: Sets all application settings to the default setting.

View[edit]

Options under the View tab.

Hide All Panes: This closes all of Motive's panes except the main viewport.


Devices pane: Opens Devices pane, or Cameras pane for Motive version 1.10 and below.

Camera Calibration pane: Opens the Calibration pane for calibrating the camera system.


Data Pane: Opens the Data Management pane for managing the recorded captures.

Assets Pane: Opens the Assets pane for managing the list of tracked assets as well as integrated devices such as force plates and data acquisition devices.

Properties Pane: Opens the Properties pane for managing the properties of selected items in Motive.


Info Pane: Opens the Info pane for monitoring real-time tracking data of a rigid body.

Builder Pane: Opens the Builder pane for creating trackable models or assets. Specifically, this pane is used for creating rigid body models and skeleton models in Motive.

Markersets Pane: Opens the Markersets pane for managing selected markerset assets.


Edit Tools Pane: Opens the Edit Tools pane.

Labeling Pane: Opens the Labeling Pane.


Graph 1 & Graph 2: Opens Graph View pane for monitoring the channel data.


Data Streaming pane: Opens the Data Streaming pane. See: Data Streaming

Status Log pane: Opens the Status Log.


Dockable Viewports: Opens additional viewports.


Reference Overlays: Opens a Reference View window which displays and overlays the 2D view from the selected reference camera.


Toolbar: Toggles display of the Toolbar on/off.

Layout[edit]

Options under the Layout tab.

Warning2.png

Note: Layout configurations from Motive versions prior to 2.0 cannot be loaded. Please re-create and update the layouts for use.

Calibrate: Displays panes applicable to system calibration. (Cameras, Perspective View, Camera Preview, Camera Calibration, Reconstruction)

Create: Displays panes applicable to asset creation and modification. (Project, Perspective View, Timeline, Skeleton, Rigid Bodies)

Capture: Displays panes applicable to capturing a take. (Project, Perspective View, Timeline)

Edit: Displays panes applicable to editing a take. (Project, Perspective View, Timeline, Edit Tools).


Create Layout: Saves the current layout. Saved custom layouts can be accessed from the drop-down menu located at the top-right corner of Motive.

Delete Layout: Deletes the saved custom layout.

Update Current: Updates the selected custom layout from the drop-down menu located at the top-right corner of Motive.

Set as Default: Sets the current layout as a default layout setup for starting Motive.


Custom Layouts: List of custom layouts that are created by the user. In the screenshot, Label Fix and Skeleton Label layouts are added as an example

Tools[edit]

Measurements: Opens the Measurement pane which contains the Volume Accuracy tool for measuring the accuracy and the Probe tool for probe measurements.

Coordinate System Tools: (For Tracking Bars only) Opens the Coordinate System Tools pane, which replaces the ground plane tools for Duo/Trio Tracking bars.

Audio Settings: Opens the Audio Capture and Playback Settings panel which allows you to select and test audio input/output devices.

Community[edit]

Options under the Community tab.

Ask A Question: Opens the NaturalPoint forums in a web browser where you can ask any question and get answers.

Documentation Wiki: Opens online Motive documentation in a default web browser.

Tutorial & Training Videos: Opens the OptiTrack Wiki.

Submit Feedback: Opens a dialog box where you may submit any comments you have.

OptiTrack Products Catalog: Opens the OptiTrack online product catalog in a web browser.

Support Forums: Opens NaturalPoint's support forum.

Help[edit]

Options under the Help tab.

OptiTrack Support: Opens the OptiTrack support site.

News: Opens NaturalPoint's news feed.

Batch Processing Help: Opens the wiki documentation page on the Motive Batch Processor.

Check For Updates: Use this if you want to learn more about upgrading Motive.

Show Quick Start: Links you to our Quick Start Guide.

Startup News Check: This is a toggle for receiving notifications for Motive updates.


Licence Folder: Opens the folder location of your license files.

Application Folders: Opens the Application Folders pane that provides easy access to folders related to Motive.

About Motive: Displays information about the version of Motive currently running.