Difference between revisions of "Motive Basics"

Line 6: Line 6:
 
  [[OptiWiki|Back to OptiWiki]] ---> [[MD_Temp| Back to Motive Documentation]]
 
  [[OptiWiki|Back to OptiWiki]] ---> [[MD_Temp| Back to Motive Documentation]]
 
----
 
----
Before diving into details on various motion capture workflows, let’s begin with a brief introduction on basic controls and navigation. This page includes information that are essential to start your capture with Motive. Especially if you are new to Motive, read through this page and learn about the basic tools. Basic configurations and navigation controls as well as directions on managing capture files are included in this page. You need to understand topics covered in this page in order to follow through contents in other Motive workflow pages. Some of the useful features are highlighted in order to improve your capture experience.  
+
Before diving into details on specific motion capture workflows, let’s begin with a brief overview of Motive controls and navigation. Especially if you are new to Motive, we recommend you read through this page and learn about Motive's basic tools, configurations and navigation controls, as well as directions on managing capture files. Understanding the topics covered on this page will help when using Motive Workflow pages. In addition, some of Motive's more useful features are highlighted to help improve your mocap experience.  
  
  
 
==File Management==
 
==File Management==
Motive saves the captured tracking data in TAK files, which are referred as Takes, and multiple Take files are managed in the [[Project Pane]]. Whether you are planning the day's shoot or incorporating a group of ad hoc Takes mid-project, creating sessions folders can help manage complex sets of data. To create a new session, simply select the New Session button (ICON) in the Project pane. Each new session will create a session folder, which is a sub-directory of the primary project folder. Project files are used to organize multiple sessions and the respective calibration settings, and you can load all related files using project files. Project pane lists capture files that are opened in Motive and the assets (marker sets, rigid bodies, and skeletons) associated with the capture.
+
Motive saves all captured tracking data and tracking models into a single Take (TAK) file, referred to as a Take.  Multiple Take files are managed in a Project (TTP) file.  Projects and takes are managed in Motive's [[Project Pane]]. Takes may be grouped into Sessions. Each new session will create a session folder, which is a sub-directory of the primary project folder. The Project Pane show the hierarchical Session / Take organization, which is mirrored in the Windows file system:
  
*'''Motive Takes (TAK)''': Each captured tracking data is saved as a Take file in Motive. This includes the data that have been recorded by each camera.
+
* Project (TTP)
*'''Motive Session folders''': Capture sessions are folders that organizes multiple similar Takes in a folder.
+
** Calibration (CAL)
*'''Motive project files (TTP)''': includes indicators to session folders and takes that are included within the project. TTP files also load up the saved calibration file for the saved capture.
+
** Session1 (Folder)
*'''Motive Calibration files (CAL)''': Calibration files saves information on the capture volume calibration. This file will be relevant only when the system setup (camera setup) has been kept constant. Read more from [[Calibration]] page.
+
*** Take1 (TAK)
 +
*** Take2 (TAK)
 +
** Session2 (Folder)
 +
*** Take3
 +
*** Take4
  
  
{{Tip|Plan the mocap session before the capture and organize a list of captures that needs to be completed. Type Take names in a spreadsheet or a text file, and Copy and paste the list into project pane, which will automatically create empty Takes with corresponding names from the pasted list.}}
+
Whether you are planning the day's shoot or incorporating a group of ad-hoc Takes mid-project, creating sessions folders can help manage complex sets of data. To create a new session, simply select the New Session button (ICON) in the Project pane.  Project files are used to organize multiple sessions and their respective calibration settings. The Project pane is the primary interface for managing these items.
 +
 
 +
 
 +
*'''Motive Take (TAK)''': A Take is a self-contained, complete motion capture recording.  The Take file includes camera calibration and 2D data, 3D reconstructed, labeled data, and any tracking model definitions (rigid bodies, skeletons, etc).
 +
*'''Motive Session folder''': A Session is a file folder that allows the user to organize multiple similar takes (e.g. Monday, Tuesday, Wednesday, or StaticTrials, WalkingTrials, RunningTrials, etc).
 +
*'''Motive project file (TTP)''': A Project file contains settings and references to all aspects of a motion capture shoot, including the current camera calibration, session and take organization, default tracking models (assets), and any project specific settings.
 +
*'''Motive Calibration files (CAL)''': A Calibration file is a standalone file that contains all required information to restore a calibrated camera volume, including the cameras used and their lense distortion parameters. This file is useful when the system setup (camera setup) has been kept constant, and can be automatically loaded at startup to provide instant access to the 3D volume. Read more from [[Calibration]] page.
 +
 
 +
 
 +
{{Tip|Plan the mocap session before the capture and organize a list of captures (shots) that need to be completed. Type Take names in a spreadsheet or a text file, and Copy and paste the list into project pane, which will automatically create empty Takes (shot list) with corresponding names from the pasted list.}}
  
  
 
==Viewports==
 
==Viewports==
In Motive, the main view port is fixed at the center of the GUI. This View Pane is used to monitor either the 2D or 3D capture data in both live and edit mode. View Pane that can be toggled between 2D and 3D view of the data. The Perspective View mode (ICON) displays the reconstructed 3D data in a 3D space, and the Camera Preview mode (ICON) shows 2D images from each individual camera in the setup. Both of these view ports are essential for monitoring the tracked data.  
+
In Motive, the main viewport is fixed at the center of the GUI. This View Pane is used to monitor either the 2D or 3D capture data in both live and edit mode. The main viewport  can be toggled between 2D and 3D views of the data. The Perspective View mode (ICON) displays the reconstructed 3D data in a 3D space, and the Camera Preview mode (ICON) shows 2D images from each individual camera in the setup. Both of these views  are essential for monitoring the tracked data.  
  
  
=====Perspective View - 3D view port=====
+
=====Perspective View - 3D viewport=====
*Used to look through the reconstructed 3D representation of the capture.
+
*Used to look through the reconstructed 3D representation of the capture, analyze marker positions, rays used in reconstruction, etc.
 
*The context menu in the Perspective View allows you to access more options related to the markers and assets in 3D tracking data.  
 
*The context menu in the Perspective View allows you to access more options related to the markers and assets in 3D tracking data.  
  
Line 43: Line 56:
  
 
==Timeline==
 
==Timeline==
The Timeline is one of the most fundamental panes in Motive. First of all, on the left-bottom corner of the Timeline, you can toggle between Live and Edit mode in Motive. In Live mode, all camera are active and the system is ready for recording.  When in Edit mode, you can access the Editor in the Timeline to navigate through captured frames. Here, you can access 3D trajectory graphs to monitor the tracked motion. This tool is often used for post-processing of the capture data. Read more about the [[Timeline Pane]].
+
The Timeline Pane provides control over Motive's 2 primary operating modes : Live and Edit.
 +
 
 +
In Live Mode, all cameras are active, the system is processing camera data, and, if calibrated, reconstructing 2D camera data into labeled and unlabeled 3D trajectories (markers).  In Live mode, the system is ready for recording, and the Timeline shows the recording controls.
 +
 
 +
In Edit Mode, The cameras are not activeMotive is processing load TAK data (pre-recorded data). In Edit Mode, the timeline shows the playback controls, including access to the frame scrubber, and the 2D Graph Editor, for accessing and editing 3D trajectory data.
 +
 
  
 
[[Image:Basics_Timeline.png|center|800 px]]
 
[[Image:Basics_Timeline.png|center|800 px]]
Line 53: Line 71:
  
 
==Navigation Controls==
 
==Navigation Controls==
Most of the navigation features in Motive (1.9.0 and above) are customizable, including both mouse and Hotkey controls.  The Hotkey Editor Pane and the Mouse Control Pane under the Edit tab allows you to customize the navigation control.
+
Most of the navigation features in Motive (1.9.0 and above) are customizable, including both mouse and Hotkey controls.  The Hotkey Editor Pane and the Mouse Control Pane under the Edit tab allows you to customize mouse navigation and keyboard shortcuts to common operations.
  
  
 
=====Default Mouse Control=====
 
=====Default Mouse Control=====
Various preset mouse control profiles are available to be implemented. Control profile presets include: Motive, Blade, Autodesk Maya, and Autodesk. You can also open the Mouse Control pane under the Edit tab in order to customize the setting for your own preference.
+
Motive comes with a variety of common mouse control 'profiles'. Control profile presets include: Motive, Blade, Autodesk Maya, and Autodesk. You can also open the Mouse Control pane under the Edit tab in order to customize the setting for your own preference.
  
 
[[Image:Basics_MouseControls.png|thumb|Mouse Controls pane used to customize the navigation mouse controls.]]
 
[[Image:Basics_MouseControls.png|thumb|Mouse Controls pane used to customize the navigation mouse controls.]]
Line 88: Line 106:
  
 
==Layouts==
 
==Layouts==
The UI layout in Motive is customizable. All panes can be docked and undocked from the UI. Each pane can be positioned and organized by drag-and-drop into the docking indicator. Furthermore, more than one UI can be stacked. When panes are stacked, their labels are added at the top of the pane, and they can be used to switch between stacked panes. Also, the layout feature in Motive allows users to save and load layout configurations suitable for different needs. There are default preset layouts for Calibration, Creating Skeleton, Capturing (Record), and Editing workflows. Custom layouts can also be saved using the Layout tab in the tool bar. Save the pane configuration by clicking the Create Layout, or Update Current, button and load it later when you need to reopen the specific layout. All saved layouts can be quickly accessed through using HotKeys.
+
The UI layout in Motive is customizable. All panes can be docked and undocked from the UI. Each pane can be positioned and organized by drag-and-drop using the on-screen docking indicators. Panes may float, dock, or stack. When stacked together, they form a tabbed window for quickly cycling through.  Layouts in Motive can be saved and loaded, allowing user's to quickly create and switch between default and custom configurations suitable for different needs. Motive has preset layouts for Calibration, Creating a Skeleton, Capturing (Record), and Editing workflows. Custom layouts can be created, saved, and set as default from the Main Menu -> 'Layout' menu item. Quickly restore a particular layout from the Layout menu, the Layout Dropdown at the top right of the Main Menu, or via HotKeys.
  
  
 
<center>[[Image:Basics_LayoutTab.png]]  [[Image:Basics_LayoutGuide.png|245 px]]</center>
 
<center>[[Image:Basics_LayoutTab.png]]  [[Image:Basics_LayoutGuide.png|245 px]]</center>

Revision as of 22:18, 28 October 2015

THIS PAGE IS UNDER CONSTRUCTION THIS PAGE IS UNDER CONSTRUCTION THIS PAGE IS UNDER CONSTRUCTION THIS PAGE IS UNDER CONSTRUCTION

THIS PAGE IS UNDER CONSTRUCTION THIS PAGE IS UNDER CONSTRUCTION THIS PAGE IS UNDER CONSTRUCTION THIS PAGE IS UNDER CONSTRUCTION



Back to OptiWiki --->  Back to Motive Documentation

Before diving into details on specific motion capture workflows, let’s begin with a brief overview of Motive controls and navigation. Especially if you are new to Motive, we recommend you read through this page and learn about Motive's basic tools, configurations and navigation controls, as well as directions on managing capture files. Understanding the topics covered on this page will help when using Motive Workflow pages. In addition, some of Motive's more useful features are highlighted to help improve your mocap experience.


File Management

Motive saves all captured tracking data and tracking models into a single Take (TAK) file, referred to as a Take. Multiple Take files are managed in a Project (TTP) file. Projects and takes are managed in Motive's Project Pane. Takes may be grouped into Sessions. Each new session will create a session folder, which is a sub-directory of the primary project folder. The Project Pane show the hierarchical Session / Take organization, which is mirrored in the Windows file system:

  • Project (TTP)
    • Calibration (CAL)
    • Session1 (Folder)
      • Take1 (TAK)
      • Take2 (TAK)
    • Session2 (Folder)
      • Take3
      • Take4


Whether you are planning the day's shoot or incorporating a group of ad-hoc Takes mid-project, creating sessions folders can help manage complex sets of data. To create a new session, simply select the New Session button (ICON) in the Project pane. Project files are used to organize multiple sessions and their respective calibration settings. The Project pane is the primary interface for managing these items.


  • Motive Take (TAK): A Take is a self-contained, complete motion capture recording. The Take file includes camera calibration and 2D data, 3D reconstructed, labeled data, and any tracking model definitions (rigid bodies, skeletons, etc).
  • Motive Session folder: A Session is a file folder that allows the user to organize multiple similar takes (e.g. Monday, Tuesday, Wednesday, or StaticTrials, WalkingTrials, RunningTrials, etc).
  • Motive project file (TTP): A Project file contains settings and references to all aspects of a motion capture shoot, including the current camera calibration, session and take organization, default tracking models (assets), and any project specific settings.
  • Motive Calibration files (CAL): A Calibration file is a standalone file that contains all required information to restore a calibrated camera volume, including the cameras used and their lense distortion parameters. This file is useful when the system setup (camera setup) has been kept constant, and can be automatically loaded at startup to provide instant access to the 3D volume. Read more from Calibration page.


Plan the mocap session before the capture and organize a list of captures (shots) that need to be completed. Type Take names in a spreadsheet or a text file, and Copy and paste the list into project pane, which will automatically create empty Takes (shot list) with corresponding names from the pasted list.



Viewports

In Motive, the main viewport is fixed at the center of the GUI. This View Pane is used to monitor either the 2D or 3D capture data in both live and edit mode. The main viewport can be toggled between 2D and 3D views of the data. The Perspective View mode (ICON) displays the reconstructed 3D data in a 3D space, and the Camera Preview mode (ICON) shows 2D images from each individual camera in the setup. Both of these views are essential for monitoring the tracked data.


Perspective View - 3D viewport
  • Used to look through the reconstructed 3D representation of the capture, analyze marker positions, rays used in reconstruction, etc.
  • The context menu in the Perspective View allows you to access more options related to the markers and assets in 3D tracking data.


Basics Perspective.png


Camera Preview - 2D view port
  • Each camera’s view can be accessed from the Camera Preview pane. It displays the images that are being transmitted from each camera. The image processing modes are displayed, including grayscale and object
  • Detected reflections are also shown in this pane, and reflections satisfies the object filters and considered as markers
  • From Camera Preview pane, you can mask certain pixel regions to exclude them from the process.


Basics CameraPreview.png


Timeline

The Timeline Pane provides control over Motive's 2 primary operating modes : Live and Edit.

In Live Mode, all cameras are active, the system is processing camera data, and, if calibrated, reconstructing 2D camera data into labeled and unlabeled 3D trajectories (markers). In Live mode, the system is ready for recording, and the Timeline shows the recording controls.

In Edit Mode, The cameras are not active. Motive is processing load TAK data (pre-recorded data). In Edit Mode, the timeline shows the playback controls, including access to the frame scrubber, and the 2D Graph Editor, for accessing and editing 3D trajectory data.


Basics Timeline.png


Application Setting

The Application Setting Pane can be accessed under the Edit tab. This pane is used to modify preferences that are related to General, Views, Skeletons, and Rigid Bodies. Note that these settings are not related to the data acquisition properties. Here, you can modify general settings such as startup settings and display options for view ports. In addition, Skeletons and Rigid Bodies tabs are used to sets the default creation setting for new assets. Many other software preferences can be modified from this pane, read and find more about available preference settings from the Application Settings Pane page. If you wish to reset the default application setting, go to Reset Application Settings under the Edit tab.


Navigation Controls

Most of the navigation features in Motive (1.9.0 and above) are customizable, including both mouse and Hotkey controls. The Hotkey Editor Pane and the Mouse Control Pane under the Edit tab allows you to customize mouse navigation and keyboard shortcuts to common operations.


Default Mouse Control

Motive comes with a variety of common mouse control 'profiles'. Control profile presets include: Motive, Blade, Autodesk Maya, and Autodesk. You can also open the Mouse Control pane under the Edit tab in order to customize the setting for your own preference.

Mouse Controls pane used to customize the navigation mouse controls.
Function Default Control
Rotate view Right + Drag
Pan view Middle (wheel) click + drag
Zoom in/out Mouse Wheel
Select in View Left mouse click
Toggle Selection in View CTRL + left mouse click


Hotkeys

Using Hotkeys can improve the speed of workflows in Motive. All default hotkeys are listed in the Motive Hotkeys page. For Motive 1.9 and above, Hotkeys can customized in the Hotkey Editor (shown below), which can be accessed under the Edit tab in the Main Tool Bar. Various actions can be assigned with a custom hotkey using the Hotkey Editor. For list of the default Hotkey settings, read through the Motive Hotkeys Page.

Basics Hotkey.png


Layouts

The UI layout in Motive is customizable. All panes can be docked and undocked from the UI. Each pane can be positioned and organized by drag-and-drop using the on-screen docking indicators. Panes may float, dock, or stack. When stacked together, they form a tabbed window for quickly cycling through. Layouts in Motive can be saved and loaded, allowing user's to quickly create and switch between default and custom configurations suitable for different needs. Motive has preset layouts for Calibration, Creating a Skeleton, Capturing (Record), and Editing workflows. Custom layouts can be created, saved, and set as default from the Main Menu -> 'Layout' menu item. Quickly restore a particular layout from the Layout menu, the Layout Dropdown at the top right of the Main Menu, or via HotKeys.


Basics LayoutTab.png Basics LayoutGuide.png