Builder pane


Main PageBuilder pane

The Builder pane can be accessed under the View tab or by clicking the Toolbar RigidBody .png icon on the main toolbar.

Overview[edit]


The Builder pane is used for creating and editing trackable models, also called trackable assets, in Motive. In general, rigid body models are created for tracking rigid objects, and skeleton models are created for tracking human motions.

When created, trackable models store the positions of markers on the target object and use the information to auto-label the reconstructed markers in 3D space. During the auto-label process, a set of predefined labels gets assigned to 3D points using the labeling algorithms, and the labeled dataset is then used for calculating the position and orientation of the corresponding rigid bodies or skeleton segments.

The trackable models can be used to auto-label the 3D capture both in Live mode (real-time) and in the Edit mode (post-processing). Each created trackable models will have its own properties which can be viewed and changed under the Properties pane. If new skeletons or rigid bodies are created during post-processing, the Take will need to be auto-labeled again in order to apply the changes to the 3D data.

  • a rigid body in Motive with auto-labeled markers
  • a skeleton in Motive with auto-labeled markers

Interface Overview[edit]

On the Builder pane, you can either create a new trackable asset or modify an existing one. Select either rigid body or skeleton at the bottom of the pane, and then select whether you wish to create or edit. Each feature will be explained in the sections below.
TrackablesPane Overview.png

Rigid Body: Create[edit]


For creating rigid bodies, select the rigid body option at the bottom and access the Create tab at the top. Here, you can create rigid body asset and track any markered-objects in the volume. In addition to standard rigid body assets, you can also create rigid body models for head-mounted displays (HMDs) and measurement probes as well.

Creating Rigid Body[edit]

Step 1.[edit]

Select all associated rigid body markers in the 3D viewport.

Step 2.[edit]

On the Builder pane, confirm that the selected markers match the markers that you wish to define the rigid body from.

Step 3.[edit]

Click Create to define a rigid body asset from the selected markers.

Info2.png

Other ways to create a rigid body

You can also create a rigid body by doing the following actions while the markers are selected:

  • Prespective View (3D viewport): While the markers are selected, right-click on the perspective view to access the context menu. Under the Rigid Body section, click Create From Selected Markers.
  • Assets pane: While the markers are selected in Motive, click on the add IconAdd.png button in the Assets pane.
  • Hotkey: While the markers are selected, use the create rigid body hotkey (Default: Ctrl +T).
Asset RBRightClick.png Asset RBbat.png

Step 4.[edit]

Once the rigid body asset is created, the markers will be colored (labeled) and interconnected to each other. The newly created rigid body will be listed under the Assets pane.

Info2.png

If the rigid bodies, or skeletons, are created in the Edit mode, the corresponding Take needs to be auto-labeled. Only then, the rigid body markers will be labeled using the rigid body asset and positions and orientations will be computed for each frame.

Creating a rigid body

Creating HMD Rigid Body[edit]

Creating an HMD rigid body in the Builder pane.

This feature can be used only with HMDs that have the OptiTrack Active HMD clips mounted.

For using OptiTrack system for VR applications, it is important that the pivot point of HMD rigid body gets placed at the appropriate location, which is at the root of the nose in between the eyes. When using the HMD clips, you can utilize the HMD creation tools in the Builder pane to have Motive estimate this spot and place the pivot point accordingly. It utilizes known marker configurations on the clip to precisely place the pivot point set the desired orientation.

Info2.png

HMDs with passive markers can utilize the External Pivot Alignment tool to calibrate the pivot point.

Steps[edit]

  1. First of all, make sure Motive is configured for tracking active markers.
  2. Open the Builder pane under View tab and click Rigid Bodies.
  3. Under the Type drop-down menu, select HMD. This will bring up the options for defining an HMD rigid body.
  4. Under the Orientation drop-down menu, select the desired orientation of the HMD. For streaming to Unity, the default orientation is +Z forward, and for streaming to Unreal Engine the default orientation is +X forward. You can also specify the expected orientation axis on the client plugin side.
  5. Hold the HMD at the center of the tracking volume where all of the active markers are tracked well.
  6. Select the 8 active markers in the 3D viewport.
  7. Click Create. An HMD rigid body will be created from the selected markers and it will initiate the calibration process.
  8. During calibration, slowly rotate the HMD to collect data samples in different orientations.
  9. Once all necessary samples are collected, the calibrated HMD rigid body will be created.

Creating Measurement Probe Rigid Body[edit]

Calibrated probe in Motive

For using OptiTrack system for VR applications, it is important that the pivot point of HMD rigid body gets placed at the appropriate location, which is at the root of the nose in between the eyes. When using the HMD clips, you can utilize the HMD creation tools in the Builder pane to have Motive estimate this spot and place the pivot point accordingly. It utilizes known marker configurations on the clip to precisely place the pivot point set the desired orientation.

For more information: Measurement Probe Kit Guide

Steps: Probe Calibration[edit]

  1. Open the Builder pane under View tab and click Rigid Bodies.
  2. Bring the probe out into the tracking volume and create a rigid body from the markers.
  3. Under the Type drop-down menu, select Probe. This will bring up the options for defining a rigid body for the measurement probe.
  4. Select the rigid body created in step 2.
  5. Place and fit the tip of the probe in one of the slots on the provided calibration block.
  6. Note that there will be two steps in the calibration process: refining rigid body definition and calibration of the pivot point. Click Create button to initiate the probe refinement process.
  7. Slowly move the probe in a circular pattern while keeping the tip fitted in the slot; making a cone shape overall. Gently rotate the probe to collect additional samples.
  8. After the refinement, it will automatically proceed to the next step; the pivot point calibration.
  9. Repeat the same movement to collect additional sample data for precisely calculating the location of the pivot or the probe tip.
  10. When sufficient samples are collected, the pivot point will be positioned at the tip of the probe and the Mean Tip Error will be displayed. If the probe calibration was unsuccessful, just repeat the calibration again from step 4.
  11. Once the probe is calibrated successfully, a probe asset will be displayed over the rigid body in Motive, and live x/y.z position data will be displayed under the Real-time Measurement section in the Measurements pane.

Steps: Sample Collection[edit]

  1. Under the Tools tab, open the Measurements pane.
  2. Place the probe tip on the point that you wish to collect.
  3. Click Take Sample on the Measurement pane.
  4. A virtual reconstruction will be created at the point, and the corresponding information will be displayed over the measurement pane. The sampled points will also be saved in the exported onto the project directory.
  5. Collecting additional samples will provide distance and angles between collected samples.
Sampling 3D points using the measurement probe.

Rigid Body: Edit[edit]


Using the Builder pane, you can also modify existing rigid body assets. For editing rigid bodies, select the rigid body option at the bottom of the Builder pane and access the Edit tab at the top. This will bring up the options for editing a rigid body.

Refine[edit]

Using the RigidBody Refinement tool for improving asset definitions.

This feature is supported in Live Mode only.

Rigid body refinement tool improves the accuracy of rigid body calculation in Motive. When a rigid body asset is initially created, Motive references only a single frame for defining the rigid body definition. The rigid body refinement tool allows Motive to collect additional samples in the live mode for achieving more accurate tracking results. More specifically, this feature improves the calculation of expected marker locations of the rigid body as well as position and orientation of the rigid body itself.

Steps[edit]

  1. Under Tools tab open the Builder pane.
  2. Select the Rigid Bodies option at the bottom of the pane and go to the Edit tab.
  3. In Live mode, select an existing rigid body asset that you wish to refine.
  4. Hold the selected rigid body at the center of the capture volume so that as many cameras as possible can clearly capture the markers on the rigid body.
  5. Press Start Refine in the Builder pane and the
  6. Slowly rotate the rigid body to collect samples at different orientations.
  7. Once all necessary samples are collected, the refinement results will be displayed.

Probe Calibration[edit]

The Probe Calibration feature under the rigid body edit options can be used to re-calibrate a pivot point of a measurement probe or a custom rigid body. This step is also completed as one of the calibration steps when first creating a measurement probe, but you can re-calibrate it under the Edit tab.

Steps[edit]

  1. In Motive, select the rigid body or a measurement probe.
  2. Bring out the probe into the tracking volume where all of its markers are well-tracked.
  3. Place and fit the tip of the probe in one of the slots on the provided calibration block.
  4. Click Start
  5. Once it starts collecting the samples, slowly move the probe in a circular pattern while keeping the tip fitted in the slot; making a cone shape overall. Gently rotate the probe to collect additional samples.
  6. When sufficient samples are collected, the mean error of the calibrated pivot point will be displayed.
  7. Click Apply to use the calibrated definition or click Cancel to calibrate again.

Location/Orientation[edit]

Options for translating and rotating the rigid body pivot point.

The Edit tab is used to apply translation or rotation to the pivot point of a selected rigid body. A pivot point of a rigid body represents both position (x,y,z) and orientation (pitch, roll, yaw) of the corresponding asset.

Info2.png

You can also use the Gizmo tools to quickly make modify the pivot point of a rigid body

Location[edit]

Use this tool to translate a pivot point in x/y/z axis (in mm). You can also reset the translation to set the pivot point back at the geometrical center of the rigid body.

Orientation[edit]

Use this tool to apply rotation to the local coordinate system of a selected rigid body. You can also reset the orientation to align the rigid body coordinate axis and the global axis.
When resetting the orientation, the rigid body must be tracked in the scene.

OptiTrack Clip Tool[edit]

The OptiTrack Clip Tool basically recalibrates HMDs with OptiTrack HMD Clips to position its pivot point at an appropriate location. The steps are basically the same as when first creating the HMD rigid body.

External Pivot Alignment[edit]

This tool can be used for HMD with passive markers.

For using OptiTrack system for VR applications, it is important that the pivot point of HMD rigid body gets placed at the appropriate location, which is at the root of the nose in between the eyes. External Pivot Alignment tool utilizes both the OptiTrack mocap system and the HMD's own tracking system (Oculus Tracker / Vive Base Stations) for precisely calculating the location of the pivot point of an HMD. When using this feature, both systems must be tracking the HMD simultaneously.

Info2.png

HMD Compatibility Notes:

  • For Motive versions 2.1 Final and later: Oculus and Vive HMDs are supported.
  • For older versions of Motive: Only Oculus HMDs are supported.
  • The corresponding native HMD tracker must be tracking the HMD along with the motion capture system simultaneously.

Steps[edit]

  1. Connect the Oculus Tracker and have the Oculus software running in the background.
  2. Launch Motive.
  3. [Motive] Create a rigid body asset from the markers on the HMD.
  4. [Motive] Open the Builder pane and access editing options for rigid bodies.
  5. [Motive] Select the HMD rigid body in Motive.
  6. [Motive → Builder pane] Under Detected Type, it should indicate Custom RigidBody.
  7. [Motive → Builder pane] Set the desired number of sample counts (Default: 750) and the desired orientation.
  8. [Motive → Builder pane] Press start to initiate the sampling process.
  9. [Motive → Builder pane] During calibration, make sure both the mocap system and the HMD tracker (Oculus Tracker / Vive Base Stations) is tracking the HMD.
  10. [Motive → Builder pane] Once it starts collecting the samples, point the HMD towards the tracker and slowly rotate it and sample different orientations.
  11. [Motive → Builder pane] When it finishes collecting samples, it will display the offset distance, in mm, between positions of the pivot point detected by the HMD tracking system and the motion capture system.
  12. [Motive → Builder pane] If the results are satisfying, press Apply to calibrate the HMD rigid body.

Spherical Pivot Placement[edit]

This feature is useful when tracking a spherical object (e.g. ball). It will assume that all of the markers on the selected rigid body are placed on a surface of a spherical object, and the pivot point will be calculated and re-positioned accordingly. Simply select a rigid body in Motive, open the Builder pane to edit rigid body definitions, and then click Apply to place the pivot point at the center of the spherical object.

Skeleton: Create[edit]

To create skeletons in Motive, you need to select the skeleton option at the bottom of the Builder pane and access the Create tab at the top. Here, you select which skeleton markerset to use, choose the calibration post, and create the skeleton model.

Creating Skeleton[edit]

Defining skeleton from a skeleton markerset.

Step 1.[edit]

From the skeleton creation options on the Builder pane, select a skeleton marker set from the Marker Set drop-down menu. This will bring up a skeleton avatar displaying where the markers need to be placed on the subject.

Step 2.[edit]

Refer to the avatar and place the markers on the subject accordingly. For accurate placements, ask the subject to stand in the calibration pose while placing the markers. It is important that these markers get placed at the right spots on the subject's body for the best skeleton tracking. Thus, extra attention is needed when placing the skeleton markers.

Info2.png

The magenta markers indicate the segment markers that can be placed at a slightly different position within the same segment.

Step 3.[edit]

Double-check the marker counts and their placements. It may be easier to use the 3D viewport in Motive to do this. The system should be tracking the attached markers at this point.

Step 4.[edit]

In the Builder pane, make sure the numbers under the Markers Needed and Markers Detected sections are matching. If the skeleton markers are not automatically detected, manually select the skeleton markers from the 3D perspective view.

Step 5.[edit]

Select a desired set of marker labels under the Labels section. Here, you can just use the Default labels to assign labels that are defined by the markerset template. Or, you can also assign custom labels by loading previously prepared marker-name XML files in the label section.

Step 6.[edit]

Next step is to select the skeleton creation pose settings. Under the Pose section drop-down menu, select the desired calibration post you want to use for defining the skeleton. This is set to the T-pose by default.

Step 7.[edit]

Ask the subject to stand in the selected calibration pose. Here, standing in a proper calibration posture is important because the pose of the created skeleton will be calibrated from it. For more details, read the calibration poses section.

Step 8.[edit]

Click Create to create the skeleton. Once the skeleton model has been defined, confirm all skeleton segments and assigned markers are located at expected locations. If any of the skeleton segment seems to be misaligned, delete and create the skeleton again after adjusting the marker placements and the calibration pose.

Info2.png

In Edit Mode

If you are creating a skeleton in the post-processing of captured data, you will have to auto-label the Take to see the skeleton modeled and tracked in Motive.

Info2.png

Virtual Reality Markersets

Skeleton markersets for VR applications have slightly different setup steps. See: Rigid Body Skeleton Markerset.

Skeleton: Edit[edit]


To create skeletons in Motive, you need to select the skeleton option at the bottom of the Builder pane and access the Edit tab at the top.

Recalibrate From Markers[edit]

Existing skeleton assets can be recalibrated using the existing skeleton information. Basically, the recalibration recreates the selected skeleton using the same skeleton markerset. This feature recalibrates the skeleton asset and refreshes expected marker locations on the assets.

To recalibrate skeletons, select all of the associated skeleton markers from the perspective view along with the corresponding skeleton model. Open the Builder pane, and open the Edit tab while Skeleton option is selected at the bottom. Make sure the selected skeleton is in a calibration pose, and click Recalibrate. You can also recalibrate from the context menu in the Assets pane or in the 3D Viewport.

Warning2.png

Skeleton recalibration do not work with skeleton templates with added markers.

  • Recalibrate from selected marker in the Assets pane.
  • Recalibrate from selected marker in the Assets pane.
  • Recalibrate from selected marker in the Perspective View pane.